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Introduction 

 

Rapid growth and development of Information Technology (IT) characterizes 

today's society. As a result, we have grown to depend on the knowledge and 

competence of an individual in the IT field. And although this dependence is 

growing from day to day,  the human right to education and information has not 

been extended to the IT field. Problems, that impact our society as a whole, 

create obstacles and distance people from the main reason and motivation for 

advancement, from the opportunity. 

Being computer illiterate in today's world means being someone who is unable to 

participate in modern society. It also means not to have opportunities. Despite 

the recognition of the European Commission, UNESCO, OECD and other relevant 

institutions on the necessity and benefits of computer literacy, there are still 

groups of people with hindered access to basic computer education (e.g. people 

with physical disabilities, people with learning difficulties, immigrant workers, the 

unemployed, people living in remote places where education is not accessible).  

This Manual, together with additional material published on Itdesk.info website, 

represent our contribution to the realization and promotion of human rights to 

education and information in the IT field. We hope that this education will help 

you to master basic computer skills and in this hope we wish that you learn as 

much as possible and become an active member of the modern IT society. 

Sincerely yours, 

ITdesk.info team  

 

 

 

  



ITdesk.info – project of computer e-education with open access 

ITdesk.info is licensed under a Creative Commons Attribution-  

Non-commercial-No Derivative Works 3.0 Croatia License  1/52 

CONTENT: 

1. WEB CONCEPTS  ..........................................................................................................................4 

1.1. Key Terms ...........................................................................................................................4 

1.1.1. Understand that the Internet supports a range of services such as the World Wide 

Web (WWW), File Transfer, email, instant messaging (IM) .....................................................4 

1.1.2. Understand the term client/server. Understand the functionality and relationship 

between the browser and the web server ................................................................................4 

1.1.3. Understand the terms domain, Uniform Resource Locator (URL), hyperlink, web 

hosting, search engine. .............................................................................................................5 

1.1.4. Understand the use of primary protocols: Transmission Control Protocol/ Internet 

Protocol (TCP/lP), Hypertext Transfer Protocol (HTTP), File Transfer Protocol (FTP) ............6 

1.2. Web Publishing ..................................................................................................................7 

1.2.1. Identify the main advantages of having a website: access to a global audience, ease 

of updating, audience interactivity and cost savings. ...............................................................7 

1.2.3 Recognize search engine optimization techniques e.g. including relevant metadata, 

including a sitemap and website links, registering with a search engine. ...............................7 

1.2.4 Recognize the factors that impact web page download speed: audio, video, 

graphical objects, animation content, and file compression ....................................................8 

1.3 Legal Issues ........................................................................................................................9 

1.3.1 Understand the term copyright and its implications for text, images, audio, and 

video available on websites ......................................................................................................9 

2. HTML ..............................................................................................................10 

2.1.       Basics of HTML ................................................................................................................. 10 

2.1.1 Understand the term Hypertext Markup Language (HTML)....................................... 10 

2.1.2 Understand the role of W3C consortium in making HTML recommendations. .......... 10 

2.2.       Using HTML .................................................................................................................. 10 

2.2.1.    Using browser to view the website source code ......................................................... 10 

2.2.3.   Use  markup tag to develop the layout of a web page: <h1>, <p> <br/>, <a href>, 

<img/> ………………………………………………………………………………………………………………………………….12 

3. CREATING A WEB PAGE  ........................................................................................................... 13 

3.1.      Design ................................................................................................................................ 13 

3.1.1.     Recognize planning and design techniques ................................................................. 13 

3.2 Using the Application ................................................................................................... 14 

3.2.1 Open, close a web authoring application. Open, close web pages. ............................ 14 

3.2.2 Create, save a new web page to a location on  a drive ................................................ 15 

3.2.3 Create, save a new web page based on an available template ................................... 16 

3.2.4 Add, edit a descriptive web page ................................................................................. 16 

3.2.5 The difference between the source code and design view ......................................... 17 

3.3 Enhancing Productivity .................................................................................................... 17 



ITdesk.info – project of computer e-education with open access 

ITdesk.info is licensed under a Creative Commons Attribution-  

Non-commercial-No Derivative Works 3.0 Croatia License  2/52 

3.3.1 Set basic preferences in the application: default preview browser, default document 

type, coding, fonts ................................................................................................................... 17 

3.3.2 Using available Help functions ..................................................................................... 18 

3.4 Text Input and Formatting ............................................................................................... 19 

3.4.1 Insert, edit, delete text ................................................................................................ 19 

3.4.2 Understand and use relative font size ......................................................................... 19 

3.4.3 Apply text formatting: bold, italic, font type and color .............................................. 20 

3.5 Forming paragraphs ........................................................................................................ 21 

3.5.1 Set  paragraph properties ............................................................................................ 21 

3.5.2 Insert, remove paragraph break, line break ................................................................ 21 

3.5.3 Create, modify numbered or graphical (bulleted) list ................................................. 22 

3.6 Page Formatting .............................................................................................................. 24 

3.6.1 Set page margins: top, bottom, left, right. .................................................................. 24 

3.6.2 Add, modify, remove a page background color, image .............................................. 24 

3.6.3 Change a web page hyperlink color: visited, active, unvisited. ................................... 25 

3.7 Hyperlinks ........................................................................................................................ 26 

3.7.1 Understand the terms absolut and relative hyperlinks ............................................... 26 

3.7.2 Insert, add, remove a hyperlink: text, image. .............................................................. 26 

3.7.3 Insert, edit, remove an e-mail hyperlink: text, image.................................................. 27 

3.7.4 Define hyperlink target: same window, new window ................................................ 27 

3.7.5 Set an anchor, insert a link to an anchor ..................................................................... 28 

3.8 Tables ............................................................................................................................... 30 

3.8.1 Insert, delete a table .................................................................................................... 30 

3.8.2 Insert, edit a table caption ........................................................................................... 31 

3.8.3     Align a table: left, center, right.................................................................................... 32 

3.8.4     Modify column width, row height. ............................................................................. 33 

3.8.5 Merge, split cells .......................................................................................................... 33 

3.8.6    Modify table border width, cell padding, cell spacing ................................................ 34 

3.8.7 Add, remove a table background, graphic, image ....................................................... 34 

4.USING OBJECTS  ......................................................................................................................... 36 

4.1.     Graphical Objects ............................................................................................................... 36 

4.1.1.    Add, remove an image on a web page ......................................................................... 36 

4.1.2.   Set, modify attributes of an image on a web page: size, border, alignment, 

alternative text ........................................................................................................................ 36 

4.2.1   Add a form to a  web page................................................................................................. 38 

4.2.2.   Add, remove single line, multi-line text fields ............................................................. 38 

4.2.3.   Add, remove form fields: drop-down, check box, radio button. ................................. 40 

4.2.4.   Set, modify form field properties: text field, drop-down, check box, radio button. .. 42 



ITdesk.info – project of computer e-education with open access 

ITdesk.info is licensed under a Creative Commons Attribution-  

Non-commercial-No Derivative Works 3.0 Croatia License  3/52 

4.2.6.     Add, remove, submit, reset buttons........................................................................... 43 

4.2.7.     Set, modify form action to send form output by email. ............................................ 43 

4.2.7      Set, modify form action to send form output by email.............................................. 44 

5. STYLES  ........................................................................................................................................ 45 

5.1 CSS Concepts .................................................................................................................... 45 

5.1.1 Understand the term Cascading Style Sheets (CSS), their use and benefits. ............... 45 

5.1.2 Recognize the main approaches to applying styles: inline, internal, external. ............ 45 

5.1.3 Understand the structure of a CSS rule: selector and declaration (property, value). 46 

5.2 Using CSS.......................................................................................................................... 46 

5.2.1 Create, save a new CSS file. ......................................................................................... 46 

5.2.2 Create, modify CSS rules: color, background, font...................................................... 47 

5.2.3 Attach an external CCS to a web page ......................................................................... 49 

6. PREPARE UPLOAD  .................................................................................................................... 50 

6.1.      Check ................................................................................................................................. 50 

6.1.1.     Identify and fix broken links in a website .................................................................... 50 

6.1.2     Recognize a correct use of content on a web page: including a last updated date, 

details of software required to open, view files, ensuring compatibility of content with 

other browsers ........................................................................................................................ 50 

6.1.3 Spell check and make necessary changes .................................................................... 50 

6.2      Publishing .......................................................................................................................... 50 

6.2.1.    Understand the process of uploading, downloading a website to and from a web 

server ....................................................................................................................................... 50 

6.2.2 Upload, download a website to and from a server ..................................................... 51 

GENERAL TERMS OF USE  ............................................................................................................. 52 

 

 

  



ITdesk.info – project of computer e-education with open access 

ITdesk.info is licensed under a Creative Commons Attribution-  

Non-commercial-No Derivative Works 3.0 Croatia License  4/52 

1. WEB CONCEPTS 

1.1. Key Terms 

1.1.1. Understand that the Internet supports a range of services such as the World 

Wide Web (WWW), File Transfer, email, instant messaging (IM) 

The Internet or "the network of networks" is a public network that connects computers 

and computer networks around the world through a common protocol (IP).  

All connected computers and networks mutually exchange information and use various 

services. Hence, the Internet is not solely the WWW, or pages and content available from 

a browser. In fact, the WWW is just one of the services that the Internet offers to its users 

although it is the most commonly used service. 

Other available services:  

File transfer - the file transfer from one computer to another. 

 E-mail (electronic mail) – it is the oldest Internet service, and it enables the 

exchange of digital messages between two or more people. 

  Instant messaging (IM) – it enables the exchange of electronic messages between 

two or more people in real time. Such as chat rooms (Gtalk, MSN, Skype, etc.) that 

also support nowadays video/ audio/ photo communication exchange. 

 

1.1.2. Understand the term client/server. Understand the functionality and 

relationship between the browser and the web server 

The Internet is probably the best-known example of a client/ server relationship. The 

difference between a client and a server is big. Here we have two computers/ programs 

where the client sends requests to a server, and the server processes requests and 

returns the results to the client. A server is typically a remote computer not visible to the 

user. 

 Web server: is the computer/ server whose entire content is visible on a website in 

a web browser. Web servers are constantly connected to the Internet. We access 

them through URL. Therefore, if we enter, for example, www.google.com in a 

web browser, we are accessing the Google server. 

 Web browser: enables browsing through websites. Its mechanisms display the 

content, retrieved from the server, in a correct and understandable way.  As such 

it is an intermediary between the user and the server. (e.g. Google Chrome, 

Firefox, Internet Explorer, etc.) 

 

 

 

 

http://www.google.com/
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1.1.3. Understand the terms domain, Uniform Resource Locator (URL), hyperlink, 

web hosting, search engine. 

The domain is a unique name on the Internet. We might say that what in real life the ID is 

for a human, this is what the domain name is for a web page. 

 

URL (Uniform Resource Locator) is another term for a web address. A URL has three 

parts: 

 protocol name (e.g., HTTP) 

 domain name/ hostname (servers address that a user wants to connect with), for 

example, www.google.com 

 file name is optional, implies the access to a file/directory into the principal 

webpage. It is separated by slash 

Therefore, when we enter http://www.google.com in the address bar in our web 

browser, the browser is instructed to connect to a server with the domain 

www.google.com by using the HTTP protocol. 

Hyperlinks are separately marked words, images and other elements on a web page that 

represent a direct link to additional information. Most often we open other web pages 

when we click on hyperlinks. Furthermore, we also might be able to open other parts of a 

web page, download content, and run applications. 

The image below shows a hyperlink, which is usually marked blue in texts and sometimes 

underlined to stand out. 

 
Web hosting: after we create a website, it is necessary to store it in a place where it is 

always available for users. We use Web hosting services/companies for this purpose. They 

own web servers that have the ability to store content. 

Search engine: Search engines allow us to search in the Internet for information, images 

and other types of files stored in various locations available throughout the network. 

Search engines work according to certain algorithms that show the user relevant, 

requested search results. At first, information from the various websites is collected and 

stored and then analyzed to organize and save them in the database for future use. When 

a user enters an inquiry into the search engine, the database is organized by an index and 

the user is presented with results that match best the entered search terms. Therefore, it 

http://www.google.com/
http://www.google.com/
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is important to understand that by using the search engine one does not search the entire 

Internet but the search engine’s database. 

Therefore, we might get different results each time we use different web engines. This 

information is important from a website owner’s view, who wants to make sure that the 

website is represented in various search engines once he created it. Otherwise, it will only 

be possible to access the website when a user enters the exact address in the web 

browser address bar. Currently, the most known search engine is “Google.” 

1.1.4. Understand the use of primary protocols: Transmission Control Protocol/ 

Internet Protocol (TCP/lP), Hypertext Transfer Protocol (HTTP), File Transfer 

Protocol (FTP) 

TCP/IP protocol: TCP / IP: This protocol is the main protocol for Internet communication. 

It defines the rules that computers need to follow to communicate with other computers 

via a network. 

TCP is responsible for separating messages. They are then send across the network in 

smaller packets (packages). They reassemble again at the destination to present the 

initially sent message. This means that a sent e– mail, for example, does not travel 

through the network in one piece. It breaks down into smaller parts that travel separately 

through the network, not necessarily through the same channel, and then reassemble, 

according to the information that each packets carries, at the destination. Each packet 

includes information to which address it should travel (IP address). It is namely the IP 

protocol that is responsible for each packet to arrive at their destination.  

 

HTTP (Hypertext Transfer protocol): is a network protocol that ensures the exchange of 

almost all types of resources on the web. With resources, we mean files, pages, images, 

search results, etc. It is basically, the web browsers language to send requests to the 

server. There is also the HTTPS version, which is a secure and encrypted version for HTTP 

communications. 

FTP(File Transfer Protocol): is used to load (upload) or retrieve (download) files between 

the client and server communication, or between two computers on the Internet. In 

other words, this protocol is responsible for file transfer on the Internet. 
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1.2. Web Publishing 

1.2.1. Identify the main advantages of having a website: access to a global audience, 

ease of updating, audience interactivity and cost savings. 

Nowadays more and more people/ companies opt to own a website. Positive sides of 

creating and having a website are: 

 It is possible to reach a broad audience in an easy way. 

 It is possible to change information from virtually anywhere in real time. If, for 

example, a website offers some products, it is possible to update prices with just a 

few clicks. 

 Web sites allow a much better relationship with customers compared to 

conventional printed materials or advertisements on television or radio. The user 

can receive information more easily, answer questions, share experiences on a 

forum (if the page has one), etc. 

 Maintaining a website is far less expensive than advertising on other media. 

Therefore, an online business can significantly reduce costs for staff, office space, 

etc. 

 Obtain information of their constumers and create a specific target of their 

promotion 

 

1.2.2. Understand the process of putting a website online: domain registration, selecting 

a web hosting service. 

The process of putting a website online consists of several steps: 

 Once we create a web page, it is necessary to register a domain, register a unique 

name that will represent the web page on the Internet. When choosing a domain 

name one should preferably take into account that the domain should not be too 

long, it should be constructed well, and customers should be able to remember it 

easily. 

 We did not reserve a spot for the webpage on the Internet by registering a 

domain, but we have only defined the website’s address. The next step is selecting 

a web hosting service or finding a company that offers servers to host a web page. 

There is a wide range of hosting providers and it is the website owner’s decision to 

choose a service that suits him the best. 

1.2.3 Recognize search engine optimization techniques e.g. including relevant 

metadata, including a sitemap and website links, registering with a search 

engine. 

Search engine optimization techniques serve to increase the probability that exactly your 

website ranks at a higher position among existing search results. In fact, it is the web 

results on the first few pages that will be visited the most during a web search. The 

further we look so decreases the results credibility, and thus the attendance of such 

websites decreases. 

Some of the available techniques are: 
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Including relevant metadata: metadata is used to list website’s relevant data. This data is 

not visible on the webpage, and their task is to provide relevant data to help search 

engines index web pages easier, which means they help search engines in ranking web 

pages. 

The basic syntax is: 

 

 
Meta element names, then contain the author's name, website description, and 

keywords linked to the web page content. 

Including site maps and web links: a sitemap is a list of all the pages that a web page 

contains. By including site maps, we make sure that all web pages are registered to the 

search engine. 

Registering to a search engine: as stated above, it is not enough to simply develop and 

publish a page, but it is necessary to inform search engines that the web page exists. 

Some of the options that Google offers are for example: 

 Add your URL -  URL adding 

 App crawling - indexing 

 Search Console- registering site maps 

 

1.2.4 Recognize the factors that impact web page download speed: audio, video, 

graphical objects, animation content, and file compression 

If the page contains, in addition to the text, a variety of other components such as video, 

sound, animation, etc. it affects the web page uploading speed. If we select these 

components in the wrong format, or if the page is overloaded with content it can lead to 

a slower web page download. The web page download speed is crucial to ensure a 

positive user experience, and it becomes even more important with the increasing mobile 

device use. 

When selecting the size recommendations are as follows: 

 Audio - .mp3 format 

 Video - .flv format 

  Graphic formats - .jpg picture in general, GIF, and PNG for images with few colors 

such as background images. 

Data compression also affects the web page download speed. The recommendation is to 

compress HTML and CSS files before putting them on a web server, in order to reduce 

their size, and thus increase the webpage download speed. 
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1.3 Legal Issues 

1.3.1. Understand the term copyright and its implications for text, images, audio, 

and video available on websites 

 

It is a fact that we can easily download many contents from various websites. However, 

this does not mean that we can further use all website content. Quite contrary, in most 

cases content is under certain copyright rules. It is only possible to use content from 

another website freely if the website explicitly states it (“open content“, “Open Source“, 

“Creative Commons“, etc.). Otherwise, it should be verified under which circumstances it 

is allowed to download and use them.  
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HTML 

2.1. Basics of HTML 

2.1.1. Understand the term Hypertext Markup Language (HTML). 

HTML is a presentational language that we use for the purpose of developing web pages. 

It is a descriptive language used to describe a document's layout, image position, font 

size, font color, etc. HTML is not a programming language, and it cannot complete tasks 

regarding programming (aritmetic or the use of variables), not even the simplest 

program logic such as, for example, the operation of addition. 

HTML pages are nothing but plain text files with HTML. Extension or .htm with 

instructions on how to display a page. Since they are ordinary text files, we can create 

them in any text editor such as, for example, Notepad. There are, of course, more 

advanced versions of visual editors also known as WYSIWYG editors - "What you see is 

what you get." These editors have the ability to display the page layout during the web 

page development. 

To describe a web page we use marked tags, that are written between < i >. Every tag is a 

command that tells the browser how and what to do, or how it should display the 

content. 

 

2.1.2 Understand the role of W3C consortium in making HTML recommendations.  

W3C Consortium is an international organization with the aim of setting standards for 

HTML use. 

Some of the recommendations are: 

 Websites internal operability on search engines: recommendations on how to use 

HTML to show equally websites in different browsers 

 Consistent document types declarations: Since international standards are 

applied, it means that we can use any HTML editor to develop a web page. 

 Enhanced availability: W3C develops recommendations also taking the visually 

impaired into consideration. 

 

2.2.  Using HTML 

2.2.1.  Using browser to view the website source code 

All browsers have the possibility to view a website source code. The image below shows 

how Internet Explorer displays the code. 

Go to View - > Source or right click on the page and select View Source. 



ITdesk.info – project of computer e-education with open access 

ITdesk.info is licensed under a Creative Commons Attribution-  

Non-commercial-No Derivative Works 3.0 Croatia License  11/52 

 
Afterwards a document will open where we can see the website code. 

 
2.2.2. Use markup tags to structure a  web page layout: <html>, <head>, <title> i <body> 

 

<html> element defines the entire document. It is the root element, and all other 

elements are located within. Like most other elements it has its starting and ending tag 

<html > and < / html >. Since most elements have a final tag, the manual will not 

separately mention it for each element. We will only point out if an element does not 

have an end tag. 

The recommendation is to use <html> tag to insert language tags that search engines 

further use. 

For English language we would therefore define <html lang = „eng" >. 

<head> element is used to store metadata, mentioned previously in the manual. 

<title> element is used to define a document's title. This title appears as the title of an 

opened browsers page or when we add a page to Favorites. 

<body> element defines the document’s body, and it contains the entire content such as 

text, images, tables, lists, etc. 

According to HTML5 standard <html >, <body > and <head > tags are not required, but it 

is certainly recommended to use them, since some browsers may produce unpredictable 

results. The problem is, namely, that there is yet no standard applicable to all browsers 

and all their versions.  

Great effort is invested to achieve page layout unification, and this is achieved in newer 

versions of browsers. However, older versions can still lead to incompatibility problems. 
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When creating a website, we should always keep in mind that different users choose 

different browsers and thus, we should try to create a website that most browsers can 

correctly display. 

2.2.3. Use  markup tag to develop the layout of a web page: <h1>, <p> <br/>, <a href>, 

<img/> 

Tags <h1 > and <h2 > refer to titles within the page. The range of tags goes from <h1 > to 

<h6> and they are arranged according to importance where <h1 > is the title with the 

greatest importance, and < h6 > of least importance. In most cases, we use a maximum of 

<h1 > and <h2 > for titles and subtitles. 

Titles are important since search engines use titles to analyze a page content and by the 

words in the title they analyze what the content might possibly be about. Under no 

circumstance should you use tags for titles to emphasize another text within the page, as 

this could result in reducing the web page ranking in search engines. 

Search engines base their popularity on how accurate their search results are. Any 

attempt to raise the page ranking, using methods that do not comply with the standards, 

is punished by marking the web page as unreliable. 

<p > is the tag for paragraph and we use it to separate particular parts of a text. 

<br/> stands for a line brake. It belongs to a group of tags that do not have a starting and 

ending tag. Therefore, it looks somewhat different and it has the sign / at the end of the 

tag. 

<a href> element consists of tag a that represents a hyperlink that we use as a link to 

another page or some element within the site, and href tag contains the location to 

which a hyperlink is moving. 

< img / > element is used to include images into a document 

 
The above code would we will see in a web browser as follows: 
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CREATING A WEB PAGE 

3.1. DESIGN 

3.1.1. Recognize planning and design techniques 

As with all jobs, before developing a web page it is necessary to make some planning and 

preparations: 

 It is necessary to determine the target audience. Namely, the web page with 

information about cooking will be probably significantly different from a web page 

with content for children. 

 It is necessary to create a story framework draft; it is necessary to set the main 

guidelines of what the web page will contain 

  The page structure has to be well thought through, and it should be easy to 

navigate the page with useful links. 

 A page layout template is connected to the general page layout. It includes all 

design information such as the table layout, background wallpaper, and the title’s 

color. 

 The navigation scheme allows users to find quickly and easily what they're 

searching for. 

 

           3.1.2. Recognize a good font. Using fonts such as Arial, Courier, Helvetica  

 

Since, in most cases, a text takes up a large part of a web page, selecting a font can have 

a major impact on the design. Generally, there are two types of fonts: Serif and Sans - 

serif. We can see their difference in the following image. Namely, serif fonts have 

additional ornaments on the letters. 

 

 
For the purpose of text legibility, serif fonts are not recommended for longer texts. 

Instead, they are recommended for titles and similar. 

Arial, Courier, and Helvetica are sans serif fonts representatives and as such they are 

suitable for web page content. Their characteristic is that they look good in almost all 

sizes. 
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3.2 Using the Application  

3.2.1 Open, close a web authoring application. Open, close web pages. 

For the manuals practical part, we use the application KompoZer and you can download it 

for free from http://www.kompozer.net/download.php. Once downloaded the 

application does not require any installation, it is enough to download the content to a 

location of your choice and to start it simply double click kompozer.exe. 

 

 
To close the application, click on X on the applications top right corner. 

To open a web page select File - > Open File and select the desired page from the menu.

 
To close the page, click on X, marked on the image below. 
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3.2.2 Create, save a new web page to a location on  a drive 

To create a new page click File -> New. A dialogue window will open as you can see in the 

following image. Choose option „A blank document“ and click Create. 

 
To save the page choose File -> Save. If the web page does not have a title, a window will 

appear where you can enter the page title.  Once you enter the title, click OK. 

 
In the next step, a dialogue window will open, where it is necessary to select where you 

want to save the web page, and then choose HTML files for the format. 
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3.2.3 Create, save a new web page based on an available template 

Select File -> New and choose in the window dialogue „A new document based on a 

template“, then select the template and click on Create. 

 
To save a web page the steps are the same as with 3.2.2. 

 

3.2.4 Add, edit a descriptive web page 

Choose Format -> Page Title and Properties. As shown on the image underneath, a 

dialogue window will open, where you should enter the title, author and description. 

Finallyclick OK. 

 
To view the page click on Browse. This step will open a web browser. 
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3.2.5 The difference between the source code and design view 

Applications at the bottom of the page give us the possibility to change how we view a 

page.  

Clicking on  Source, we view the page code while clicking on the button Preview we can 

see the web page layout (design view). 

 

3.3  Enhancing Productivity 

3.3.1 Set basic preferences in the application: default preview browser, default 

document type, coding, fonts 

Default Browser 

Go to Tools -> Options -> Applications and according to the image below set up the 

desired properties. In this case, we chose Chrome as the default browser. 
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Assigned document type and coding: 

Go to Tools -> Options -> Advanced and define the settings according to preference/need 

in the Markup section. The HTML4 and the XHTML are almost the same, except for little 

differences in the code, but not remarkable in the final design. In the he DTD, 

„Transitional“ mode is for presentation atributes, unlike „strict“ mode where the 

presentation attributes are excluded. 

 
Fonts: 

To define fonts, go to  Tools -> Options -> Fonts and select the desired settings. 

 

3.3.2 Using available Help functions 

The Help Center is available when you click Help in the main menu or click „F1“. After that, 

a new dialogue window will open where we can search for information according to 

various criteria. 
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3.4 Text Input and Formatting 

3.4.1 Insert, edit, delete text 

For manipulating the text select Preview at the bottom of the application and then enter 

the text as if using a regular text editor. 

 

3.4.2 Understand and use relative font size 

The font size can be set up in relative accordance with other web page elements which 

leads to a better legibility. Setting a relative size also gives the user the option to change 

the text size in a browser. 
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To set a relative size select the text that you would like to format and then go to Format -

> Size and select one of the offered sizes. 

 

3.4.3 Apply text formatting: bold, italic, font type and color 

Form a bold text: mark the desired text and choose Format -> Text Style -> Bold 

Form an italic text: mark the desired text and choose Format -> Text Style -> Italic 

Font change: mark the desired text and choose Format -> Font -> change to the desired 

font 

Change the color: mark the desired text and choose Format -> Text Color -> change to the 

desired color 
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3.5 Forming paragraphs 

3.5.1 Set  paragraph properties 

The paragraph properties are under Format: 

 Increase/Decrease Indent 

 Align  

To set up properties select a paragraph and select desired properties. 

 

3.5.2 Insert, remove paragraph break, line break 

Enter 2 arbitrary sentences, mark them and define as a paragraph. 

 
Place the cursor in front of the second sentence and press ENTER. As a result, we have 

created a break paragraph, or we can say that now two sentences represent two 

paragraphs.  
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To remove a break, place the cursor in front of the second sentence and press 

BACKSPACE on the keyboard. 

To create a sentence break, instead of pressing ENTER press simultaneously SHIFT + 

ENTER. The result is a break within a sentence. To remove a sentence break place the 

cursor in front of the second sentence and press BACKSPACE. 

Therefore, the paragraph break creates a new paragraph while the sentence break just 

jumps into a new row.  

3.5.3 Create, modify numbered or graphical (bulleted) list 

To create a list, mark elements chosen to be part of the list and go on Format -> List -> 

Numbered/Bulleted. 

 
To modify it mark the list and go to Format -> List -> List properties. 
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Afterward, we can see a dialogue window where we can arrange the list to our wishes– 

modify the list type, modify tags, modify an entire list or just parts of it, etc. 
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3.6 Page Formatting 

3.6.1 Set page margins: top, bottom, left, right. 

To set up margins go to File -> Page Setup and select in the open dialogue window 

Margins & Header/Footer section where you can then set up the size of margins. 

 

3.6.2 Add, modify, remove a page background color, image 

Go to Format -> Page Colors and Background. Select in the open dialogue window Use 

custom colors and click on the field next to the word Background. If you wish to upload a 

background picture, click on the map icon. Choose the desired picture and then click 

Open. 
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If you select the option to define the background color, a window will open, where you 

can select the color. 

 
Once you selected the color, click OK.  

3.6.3 Change a web page hyperlink color: visited, active, unvisited. 

Go to Format -> Page Colors and Background.  

You can define the desired color by clicking the boxes next to Link Text, Active Link Text, 

and Visited Link Text. 
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3.7 Hyperlinks 

3.7.1 Understand the terms absolut and relative hyperlinks 

We use the term hyperlink for a text, image or another element that, by clicking on it, 

leads us to another location. 

 Absolut hyperlink leads to a location outside the currently visited web page  

 Relative hyperlink leads to a page within the web page. For example, a link from 

one of the pages to the main page 

3.7.2 Insert, add, remove a hyperlink: text, image. 

Open the web page in Preview mode and select the text intended for a hyperlink. 

 
Then click on the Link icon. 

 
This step will open a dialogue window in which you can enter the second address 

location. 

 
Steps are the same for a relative link only that by clicking on the map icon, you should be 

able to find the location. 
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For the purpose of this operation, the initially marked text will be colored blue and 

underlined on the web page to show that it is a hyperlink. 

 
If we chose a picture to become a hyperlink, the procedure is entirely the same however 

it is necessary first to add the picture to a page. You can do so by going to Insert -> Image  

and select the desired picture.  

To remove a hyperlink, mark the hyperlink text and right-click your mouse and select 

option Remove links. 

 

3.7.3 Insert, edit, remove an e-mail hyperlink: text, image. 

To insert e-mail hyperlink, the steps are the same as for inserting a regular hyperlink with 

the difference that we enter an e-mail address instead of a web page address and 

selectthe box „The above is an email address“

 
 

3.7.4 Define hyperlink target: same window, new window 

When opening hyperlinks, there are two options: you can open a new page instead of the 

existing which means that a currently opened page closes, or that a new page opens in a 

new browser window while the currently opened page remains still open. 

The instructions for the beginning are the same as for inserting links, and the option to 

open in a new or the same window will be defined by marking in Target section "link is to 

be opened" and then select from the drop-down menu the desired option. 
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3.7.5 Set an anchor, insert a link to an anchor 

Anchor is a hyperlink that shifts the focus from one part of the text within the page onto 

another text within the page. Usually, we use them on websites that are quite long so 

that a user does not have to scroll the bar too many times. The image below shows one 

form of anchor link implementation. When clicking on any of the links the focus moves to 

a desired section. 

 
To create an anchor link, it is necessary to mark a subtitle in the text and click the Anchor 

icon. 

 

 
We need to define the anchor link name in the open dialog box. This is the name that will 

be visible to users. 

After repeating the procedure for all desired anchor links we need to create a table of 

contents that will be visible to the user (as in the example above with Wikipedia). 

At the beginning of the page list all sections that you have defined as anchor links. 
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Select the first in the line (in this case Uvod (Introduction)) and click on the Link icon. 

The locations list shows all locations that were defined earlier for an anchor. 

 
Select the desired location, click OK, and repeat the process for the rest. 

This procedure we do not use much in praxis with short texts; we recommend it solely for 

websites with large content. 
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3.8 Tables 

3.8.1 Insert, delete a table 

To insert a table click on the Table icon in the main menu bar. 

 
As a result, a dialog box will open where we can then select desired properties. 

 
After selecting the properties within the workspace, we can see a plotted table where 

you can enter desired values. 

 
To delete the table position the cursor within the table and go to Table -> Delete, and 

then choose Table. As seen in the image it is only possible to delete certain parts of the 

table, such as columns and rows. 



ITdesk.info – project of computer e-education with open access 

ITdesk.info is licensed under a Creative Commons Attribution-  

Non-commercial-No Derivative Works 3.0 Croatia License  31/52 

 

3.8.2 Insert, edit a table caption 

Click anywhere within the table and go to Table -> Table properties. 

In the dialog box, determine where you want to insert the title. 

 
In accordance with the selection in the workspace a place will be created to enter a title. 
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3.8.3 Align a table: left, center, right 

Click anywhere within the table and go to Table -> Table properties and under Table 

Alignment select the desired alignment. 

 

Insert, delete  columns and rows 

To insert column lines go to Table - > Insert, and then select the desired operation. 

 
To delete select the desired row/column you want to delete go to Table - > Delete, and 

select the desired option. 
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3.8.4 Modify column width, row height. 

Go to Format - > Table cell properties. Open Cells window and then select the Selection 

part Row and define desired settings. 

 

3.8.5 Merge, split cells 

To merge cells select the cells you want to merge and right-click the mouse and select 

from the menu " Join Selected Cells". 

 
To separate cells select the desired cell and right click the mouse and select Split cell. 
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3.8.6 Modify table border width, cell padding, cell spacing 

Click anywhere within the table and go to Table - > Table properties. 

To create table borders position the cursor within the Table window and define the 

settings in the Borders and Spacing section. 

 

To define cell properties open Cells window in the same dialog box. 

 

 Border -> define the thickness of the border line 

 Cell Spacing -> define the space between the cells in the spreadsheet  

 Cell Padding -> defines the distance between cell content and cell borders 

3.8.7 Add, remove a table background, graphic, image 

Change the color of individual cells: select the desired cell and go to Table - > Table or Cell 

Background Color and choose the desired color. 

Change the table color: go to  Table - > Table or Cell Background Color and choose the 

color. You could apply the color to the selected cells or the complete table. 
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Image inside the cell/ table: click anywhere within the table and then select <table > tag 

at the bottom of the page. 

 
After you right-click the mouse, a menu will open where we need to select Inline styles. 

 
In the open dialog box select the image. 
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4.USING OBJECTS 

4.1. Graphical Objects 

4.1.1. Add, remove an image on a web page 

Position the cursor on the page where we want to insert an image and click on the Image 

icon 

 
Afterward, find the desired image in the open dialog box. 

 
To delete an image, it is enough to mark it and click on BACKSPACE on your keyboard. 

 

4.1.2. Set, modify attributes of an image on a web page: size, border, alignment, 

alternative text 

Select the image on the page, right-click your mouse and select Image properties. 
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A dialog box will appear where you can define desired properties. 

 
In the Location window, we can modify the alternative text. It is a text that is displayed 

when the mouse hovers over the image. In the Dimension window, we can change the 

image size. In the Appearance window, it is possible to define the type for border and 

alignment. In Link window, you could convert into a hyperlink, just as any other hyperlink. 
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4.2. Forms 

4.2.1  Add a form to a  web page  

 

Position the cursor within the site where we want to add a contact form and click on the 

Form icon. 

 

Afterward, a dialog box will appear where we need to to enter certain properties: 

 Form  name 

 In Action URL enter the email address you wish to use to send answers to 

customers questions if needed. Before entering the address write mailto: 

 In the Method field select POST  

 
Within the page, a blue plotted field appears that shows where the form begins and ends. 

 

4.2.2. Add, remove single line, multi-line text fields 

Add one line: 



ITdesk.info – project of computer e-education with open access 

ITdesk.info is licensed under a Creative Commons Attribution-  

Non-commercial-No Derivative Works 3.0 Croatia License  39/52 

Within the blue plotted field enter, for example, Name and then select Form Field under 

Form. 

 
In the open dialog box select a field type and define a field name. 

 
The result should look like the image below. 

 
Add more lines: 

The steps are the same except you need to select Form - > Text Area. In the dialog box 

that will appear after, we can define desired properties. 
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Depending on the entered properties, the result should roughly look like the following: 

 

4.2.3.Add, remove form fields: drop-down, check box, radio button. 

Drop -down : click on Form -> Form field -> Selection list. In the dialog box that will open 

after define the list name (in this case the Interests), and add the elements by clicking on 

the button. 

 
Checkbox: click on Form -> Form field - > and in the field Field type select Checkbox and 

define the settings to your liking. If it is necessary to add more checkboxes, repeat the 

process for each checkbox. 
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Radio button : select Form -> Form field -> Radio button. Define properties and click OK. 

If you need to add more radio buttons repeat the process for each. The characteristic of a 

radio button, unlike the checkbox, is that we can only highlight one at a time. 

The image below shows, for example, a contact form: 
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4.2.4. Set, modify form field properties: text field, drop-down, check box, radio button. 

 

To change the settings of drop-down element highlight it and select Format -> Selection 

List Properties. 

 
To change text fields settings, checkbox and radio button select the desired element and 

go to Format - > Form Field Properties. 

 
In both cases, the same form will open as when adding fields where we then could make 

the modification.  
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4.2.6.Add, remove, submit, reset buttons. 

Go to Form -> Form Field and select under the Field type the submit or reset button. 

 
Once we click on a Submit button, it's task is to forward entered information. 

Reset button cancels everything entered into elements in the form. 

To remove the mentioned fields, we only need to mark them and click DELETE. 

 

4.2.7. Set, modify form action to send form output by email. 

Select the desired button, right-click the mouse and select Form Field Properties. 
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4.2.7 Set, modify form action to send form output by email  

 

These settings are defined in the first step of creating forms (form name, address...). If 

you wish to modify them, click anywhere within the form, and right-click the mouse and 

select Form Properties.  
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5. STYLES 

5.1 CSS Concepts  

5.1.1 Understand the term Cascading Style Sheets (CSS), their use and benefits. 

We use CSS to edit the HTML document's style. It is possible to define elements layout 

through HTML itself, but the recommendation is to separate the elements definition from 

the layout definition. 

5.1.2 The main advantage of CSS is that it can define the style for all elements in one 

spot, for example, it is possible to define in one spot the background color for all 

website pages, while with HTML we need to define it for each site separately. 

Other advantages of using CSS are faster uploading, easier editing,  faster 

development and greater control over the layout.Recognize the main approaches 

to applying styles: inline, internal, external. 

External approach: in this approach CSS definitions are located outside the HTML 

document. This approach makes it possible to separate completely the page content 

from the layout itself. CSS files are files that contain only CSS definitions and have the 

extension " CSS ", for example mySite.css. 

To apply styles listed in a CSS file to an HTML document it is necessary to link them, and 

we do this by including a CSS file in the <head > section of an HTML document. 

<head> 

<title> Web design </title> 

<link rel="stylesheet" type="text/css" href="myStyle.css"/> 

</head> 

It is necessary to repeat the procedure for each page within a web page. 

Internal approach: in this case the CSS definitions are not within another file, but are 

within the HTML file. This way, we only define the specific page style with added CSS 

definition. We may use this for example when we only want to specify a particular style 

for only one page. So, all other websites would include external CSS file, in a given page  

CSS would be defined within. 

To define an internal style , style rules must be added in <head> section within the <style> 

tag . 

 

The above example will define, that for the web page to which body this definition is 

added, it will have a red background color. 

Inline: in this approach we define the style attribute within the element tags to which we 

want t to apply a specific style. 

<p style = "color: red ; " > This is a paragraph . < / p > 

In this case, only the color of this paragraph would be red. 

We do not recommended this approach since it looses the above-mentioned benefits. 
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5.1.3 Understand the structure of a CSS rule: selector and declaration (property, 

value). 

 Selector: this is the HTML element that we need to apply to a style 

 Declaration: is the style that we want to apply to a certain element. 

Each declaration consists of 2 parts: 

 Property: we use this attribute to add value (e.g., , background color) 

 Value: the value that we assign to an attribute. 

 

Any declaration must be located within curly brackets and must end with „;“. 

Therefore, the rule that defines that the background color of an HTML document body 

should be green would look like this: 

body {background - color: green ; } 

 

5.2 Using CSS  

5.2.1 Create, save a new CSS file. 

Click on the CSS icon on the toolbar 

 
It will open a dialog box where we then need to do the following steps 

 

 Click on " internal stylesheet " in Sheets and Rules section 

 Then click on palette in upper left corner and select Linked stylesheet 

 Click on Create stylesheet 
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 Click again on "internal stylesheet" in Sheets and rules section 

 Click on Export stylesheet and switch to exported version. 

 Give the file a name and select .css extension 

 Click on Save. 

 

5.2.2 Create, modify CSS rules: color, background, font. 

Click on CSS icon in the toolbar and then select a file. To demonstrate functionality we 

selected the body element. 
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To define settings click on Create Style Rule. 

To select the background color click on Background and then on the box next to Color, 

which will open a color menu. 

 
To define the font click on Text window where you can then select desired settings. 

 
Once you have defined all settings,  click on OK. 
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5.2.3 Attach an external CCS to a web page 

To apply the defined styles to an HTML document, it is necessary to define a <head> 

element to the CSS file containing styles definitions. 

 

<head> 

  <title></title> 

  <link rel="stylesheet" href="mojStil.css" type="text/css"> 

</head> 
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6. PREPARE UPLOAD 

6.1. Check 

6.1.1. Identify and fix broken links in a website 

An important step to do once we finish the website is to check all the hyperlinks on the 

page so that, for example, it would not happen that we click on a hyperlink that leads to 

nowhere, or perhaps leads to the wrong spot. 

 

6.1.2 Recognize a correct use of content on a web page: including a last updated date, 

details of software required to open, view files, ensuring compatibility of 

content with other browsers  

The next important step before publishing the website, is to check if we have included all 

important information such as information when the page has been updated last (users 

have more trust in websites that are regularly updated). 

Specify what is required for all web page elements that might, for example, require some 

additional software to use/open them (for example for pdf documents note that it is 

necessary to have Adobe Reader). 

It is certainly important to check how the page looks like in different browsers to ensure 

that the appearance is everywhere the same. If for any reason you are not able to adapt 

the website to a particular browser point out on the website that it is recommended to 

use perhaps a different browser to make the user experience complete. We have 

previously mentioned that still not all browsers support all available options, so it can 

happen that, for example, we can't display some format in some web browsers. 

6.1.3 Spell check and make necessary changes 

Another thing that is certainly important is to check for spelling errors since they can 

negatively affect the user. KompoZer has a built in option for spell check that we can run 

by going on Edit -> Check Spelling and simply continue using it like any other spell 

checker. 

6.2 Publishing 

6.2.1. Understand the process of uploading, downloading a website to and from a web 

server 

Once we create a web page it should be stored in a spot where it is available to general 

public. That is, it is necessary to publish it on the Internet. 

The process of uploading a web page on the server is based on the transfer of files on the 

Web hosting server. In the introduction we talk about choosing a domain name and a 

web host. Once we upload a web page to the server, it connects to a URL and becomes 

visible on the Internet. 
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When users want to access your site, they first need to enter the URL. Once they click on 

ENTER, a copy of your page is downloaded from the server to their computer and they 

can view the page. 

 

6.2.2 Upload, download a website to and from a server 

Once you reserve a hosting space, you can upload the web page to a web server. 

Go to File -> Publish, and then enter the required information in the dialogue box. The 

requested information you will receive after registering a domain and reserving a web 

space. 
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GENERAL TERMS OF USE 

The web page www.ITdesk.info was initiated by the organization „Otvoreno 
društvo za razmjenu ideja - ODRAZI“ in compliance with actively promoting the 
human right to free access to information and the human right to education. 

Feel free to copy, distribute this document, under the condition that you do not 
make changes to it! 

The exclusive right to all programs and services listed on ITdesk Home website on ITdesk.info web 
address belongs solely to their respective authors. Microsoft, Windows, and Windowsxx are 
registered trademarks of Microsoft Corporation. Other trademarks used on ITdesk Home Website are 
the sole property of their respective owners. If you have questions about using or redistributing any 
program, please contact the program's author. Any further questions send to us at info@itdesk.info. 

___________________________________ 

These websites contain links to other Web sites or resources. ITdesk.info team is NOT responsible for 
the text and/or advertising content or products offered on these sites/sources, as it is NOT 
responsible for any content that is available through them; It is not responsible for the possibility of 
their use or the accuracy of their content. The use of such links is at your own risk. Also, ITdesk.info 
team does not guarantee: 

 
• that the content on this website is free from error or suitable for any purpose, 
• that these websites or web services will function without error or interruption, 
• it will be appropriate for your needs, 
• that implementing such content will not violate patents, copyrights, trademarks or other third 
party rights  
 
If you do not agree to the general terms of use or if you are not satisfied with the web pages that we 
provide, stop using this website and web services. ITdesk.info team is not responsible to you or any 
third party for any resulting damages, whether direct, indirect, incidental or consequential, 
associated with or resulting from the use or misuse of this website or web services. Although your 
claim may be based on warranty, contract violation or any other legal footing, regardless whether we 
are informed about the possibility of such damages, we shall be released from all liability. Accepting 
the limitations of our responsibilities is a necessary prerequisite of using these web pages and web 
services. 

All listed software in this document or other documents published on ITdesk.info website are listed 
only for educational purposes, and we do not prefer, in any way, one software over another. Any 
statement that we prefer some software over another, mentioned or not mentioned in the materials, 
will be considered false statement. Our direct and unconditional support is given to open source 
software that allow users to become, without any obstacles, digitally literate, to use a computer and 
participate in the modern information society. 
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